Even the mapping didnot lost before uploading,it may failed to display after uploading. This is because the model uses multi/sub-materials.

Sometimes designers didnot find this material in the material editor due to redundant materiars. In fact, many materials in the editor are not necessarily applied in the scene. 

  1. Open the model and press M. Reset the material editor first to remove all the interference materials.

2. Then click Get Material to open the material browser to check the material in the scene, you will find the multi/sub-material appears.

3. Dubble click this material and move the material to the material editor.

4. If there are triangles appears on the 4 corners of the material editor box, it means that the material is being applied in the model.Then you need to split the script, click the link below to download the script.

LINK:https://drive.google.com/file/d/1NTsU4vbrKP8XyGinzdxZxR4ghiS_3LMx/view
5. Chose the model, click explode to split the model (Ignore this step if you didnot group the model)

6. Right Click and convert the model to the editable mesh (very important step).

7. Run the script after selecting the model.


8. Select this script and open, we will find that the triangles on the four corners of the material editor box disappears.

9. Group the model and upload to coohom after fininshing these steps, you will find the problem is solved.


Related Link:
How to Center the Model?
Model Upload Errors
Coohom 3ds Max & SketchUp Model Upload Requirements

Did this answer your question?